summaryrefslogtreecommitdiff
path: root/modules/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common.nix')
-rw-r--r--modules/common.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/modules/common.nix b/modules/common.nix
new file mode 100644
index 0000000..747a9cc
--- /dev/null
+++ b/modules/common.nix
@@ -0,0 +1,17 @@
1{ config, pkgs, ... }:
2
3{
4 programs.home-manager.enable = true;
5 home.sessionVariables = {
6 PATH = "$PATH:$HOME/.bin";
7 EDITOR = "nvim";
8 MANPAGER = "nvim +Man!";
9 };
10
11 imports = [
12 ./lf.nix
13 ./fzf.nix
14 ./git.nix
15 ./zsh.nix
16 ];
17}