summaryrefslogtreecommitdiff
path: root/darwin/home.nix
diff options
context:
space:
mode:
Diffstat (limited to 'darwin/home.nix')
-rw-r--r--darwin/home.nix56
1 files changed, 56 insertions, 0 deletions
diff --git a/darwin/home.nix b/darwin/home.nix
new file mode 100644
index 0000000..5e52de6
--- /dev/null
+++ b/darwin/home.nix
@@ -0,0 +1,56 @@
1{ config, pkgs, ... }:
2
3{
4 home.username = "shubh";
5 home.homeDirectory = "/Users/shubh";
6
7 # You should not change this value, even if you update Home Manager. If you do
8 # want to update the value, then make sure to first check the Home Manager
9 # release notes.
10 home.stateVersion = "23.05";
11
12 home.packages = with pkgs; [
13 git
14 unzip
15 wget
16 gnupg
17 pass
18 tmux
19 fzf
20 docker
21 neovim
22 pinentry_mac
23 # (pkgs.nerdfonts.override { fonts = [ "FantasqueSansMono" ]; })
24 ];
25
26 programs.home-manager.enable = true;
27 programs.zsh = {
28 enable = true;
29 enableCompletion = true;
30 shellAliases = {
31 ll = "ls -l";
32 v = "nvim";
33 o = "xdg-open";
34 t = "tmux";
35 };
36 oh-my-zsh = {
37 enable = true;
38 plugins = [ "git" "kubectl" "sudo" ];
39 theme = "robbyrussell";
40 };
41 };
42 programs.fzf = {
43 enable = true;
44 enableZshIntegration = true;
45 defaultOptions = [ "--height 40%" "--layout=reverse" "--border" ];
46 };
47 programs.git = {
48 enable = true;
49 userEmail = "ssaini@fispan.com";
50 userName = "Shubham Saini";
51 signing = {
52 key = "E0404DDE4BCF9DB5";
53 signByDefault = true;
54 };
55 };
56}