summaryrefslogtreecommitdiff
path: root/hosts/oracle/hardware-configuration.nix
diff options
context:
space:
mode:
authorShubham Saini <me@ubh.sh>2023-09-25 10:25:31 +0000
committerShubham Saini <me@ubh.sh>2023-09-25 10:25:31 +0000
commitdad139cd5b4d575d29aa5b3ace3003fc51332c10 (patch)
treea5df9e48bf3d890d242fe0876a858219803ca6a1 /hosts/oracle/hardware-configuration.nix
init
Diffstat (limited to 'hosts/oracle/hardware-configuration.nix')
-rw-r--r--hosts/oracle/hardware-configuration.nix42
1 files changed, 42 insertions, 0 deletions
diff --git a/hosts/oracle/hardware-configuration.nix b/hosts/oracle/hardware-configuration.nix
new file mode 100644
index 0000000..1d57a92
--- /dev/null
+++ b/hosts/oracle/hardware-configuration.nix
@@ -0,0 +1,42 @@
1# Do not modify this file! It was generated by ‘nixos-generate-config’
2# and may be overwritten by future invocations. Please make changes
3# to /etc/nixos/configuration.nix instead.
4{ config, lib, pkgs, modulesPath, ... }:
5
6{
7 imports =
8 [ (modulesPath + "/installer/scan/not-detected.nix")
9 ];
10
11 boot.initrd.availableKernelModules = [ "nvme" "xhci_pci" "usb_storage" "sd_mod" ];
12 boot.initrd.kernelModules = [ ];
13 boot.kernelModules = [ "kvm-amd" ];
14 boot.extraModulePackages = [ ];
15
16 fileSystems."/" =
17 { device = "/dev/disk/by-uuid/84cae4ab-2829-4af1-9fe8-1a57128b1fa1";
18 fsType = "ext4";
19 };
20
21 boot.initrd.luks.devices."luks-8bf40ec5-be29-41f3-97c8-ed6a6beec6d3".device = "/dev/disk/by-uuid/8bf40ec5-be29-41f3-97c8-ed6a6beec6d3";
22
23 fileSystems."/boot" =
24 { device = "/dev/disk/by-uuid/2B72-E7BD";
25 fsType = "vfat";
26 };
27
28 swapDevices =
29 [ { device = "/dev/disk/by-uuid/3815a775-9072-4703-ab1d-267fe1287bf8"; }
30 ];
31
32 # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
33 # (the default) this is the recommended approach. When using systemd-networkd it's
34 # still possible to use this option, but it's recommended to use it in conjunction
35 # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
36 networking.useDHCP = lib.mkDefault true;
37 # networking.interfaces.enp2s0.useDHCP = lib.mkDefault true;
38 # networking.interfaces.wlp3s0.useDHCP = lib.mkDefault true;
39
40 nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
41 hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
42}