summaryrefslogtreecommitdiff
path: root/home.nix
diff options
context:
space:
mode:
authorShubham Saini <me@ubh.sh>2023-09-25 10:25:31 +0000
committerShubham Saini <me@ubh.sh>2023-09-25 10:25:31 +0000
commitdad139cd5b4d575d29aa5b3ace3003fc51332c10 (patch)
treea5df9e48bf3d890d242fe0876a858219803ca6a1 /home.nix
init
Diffstat (limited to 'home.nix')
-rw-r--r--home.nix79
1 files changed, 79 insertions, 0 deletions
diff --git a/home.nix b/home.nix
new file mode 100644
index 0000000..7de67a9
--- /dev/null
+++ b/home.nix
@@ -0,0 +1,79 @@
1{ config, pkgs, ... }:
2
3{
4 home.username = "shubh";
5 home.homeDirectory = "/home/shubh";
6
7 # You should not change this value, even if you update Home Manager. If you do
8 # want to update the value, then make sure to first check the Home Manager
9 # release notes.
10 home.stateVersion = "23.05";
11
12 home.packages = with pkgs; [
13 git
14 unzip
15 wget
16 gnupg
17 pinentry
18 wl-clipboard
19 pass
20 tmux
21 fzf
22 firefox
23 libreoffice-qt
24 # (pkgs.nerdfonts.override { fonts = [ "FantasqueSansMono" ]; })
25 ];
26
27 programs.home-manager.enable = true;
28 programs.zsh = {
29 enable = true;
30 enableCompletion = true;
31 shellAliases = {
32 ll = "ls -l";
33 v = "nvim";
34 o = "xdg-open";
35 t = "tmux";
36 update = "sudo nixos-rebuild switch --flake ~/nix";
37 };
38 history = {
39 size = 10000;
40 path = "${config.xdg.dataHome}/zsh/history";
41 };
42 oh-my-zsh = {
43 enable = true;
44 plugins = [ "git" "kubectl" "sudo" ];
45 theme = "robbyrussell";
46 };
47 };
48 programs.fzf = {
49 enable = true;
50 enableZshIntegration = true;
51 defaultOptions = [ "--height 40%" "--layout=reverse" "--border" ];
52 };
53 programs.git = {
54 enable = true;
55 userEmail = "me@ubh.sh";
56 userName = "Shubham Saini";
57 signing = {
58 key = "E0404DDE4BCF9DB5";
59 signByDefault = true;
60 };
61 };
62
63 services.gpg-agent = {
64 enable = true;
65 pinentryFlavor = "qt";
66 };
67
68 xdg = {
69 userDirs = {
70 enable = true;
71 desktop = "\$HOME/desktop";
72 documents = "\$HOME/docs";
73 download = "\$HOME/downloads";
74 pictures = "\$HOME/pics";
75 music = "\$HOME/music";
76 videos = "\$HOME/vids";
77 };
78 };
79}