summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorShubham Saini <ssaini@fispan.com>2023-09-26 06:28:12 +0000
committerShubham Saini <ssaini@fispan.com>2023-09-26 06:28:12 +0000
commitd19be69fbe421fd2b6598a93414146389ed75491 (patch)
treeabf6e146657cacf8593d31f3bb0a42dd18893fd1 /flake.nix
parentdad139cd5b4d575d29aa5b3ace3003fc51332c10 (diff)
added darwin
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix25
1 files changed, 24 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 7f3d0b9..159b4be 100644
--- a/flake.nix
+++ b/flake.nix
@@ -7,9 +7,14 @@
7 url = "github:nix-community/home-manager/release-23.05"; 7 url = "github:nix-community/home-manager/release-23.05";
8 inputs.nixpkgs.follows = "nixpkgs"; 8 inputs.nixpkgs.follows = "nixpkgs";
9 }; 9 };
10
11 darwin = {
12 url = "github:lnl7/nix-darwin/master";
13 inputs.nixpkgs.follows = "nixpkgs";
14 };
10 }; 15 };
11 16
12 outputs = { self, nixpkgs, home-manager, ... }: { 17 outputs = { self, nixpkgs, darwin, home-manager, ... }: {
13 nixosConfigurations = { 18 nixosConfigurations = {
14 oracle = nixpkgs.lib.nixosSystem { 19 oracle = nixpkgs.lib.nixosSystem {
15 system = "x86_64-linux"; 20 system = "x86_64-linux";
@@ -28,5 +33,23 @@
28 ]; 33 ];
29 }; 34 };
30 }; 35 };
36 darwinConfigurations = {
37 morpheus = darwin.lib.darwinSystem {
38 system = "x86_64-darwin";
39 modules = [
40 {
41 imports = [ ./hosts/morpheus/configuration.nix ];
42 }
43 home-manager.darwinModules.home-manager
44 {
45 home-manager.useGlobalPkgs = true;
46 home-manager.useUserPackages = true;
47 home-manager.users.shubh = {
48 imports = [ ./darwin/home.nix ];
49 };
50 }
51 ];
52 };
53 };
31 }; 54 };
32} 55}