summaryrefslogtreecommitdiff
path: root/venv/lib/python3.7/site-packages/pip-10.0.1-py3.7.egg/pip/_vendor/html5lib/__init__.py
diff options
context:
space:
mode:
authorShubham Saini <shubham6405@gmail.com>2018-12-11 10:01:23 +0000
committerShubham Saini <shubham6405@gmail.com>2018-12-11 10:01:23 +0000
commit68df54d6629ec019142eb149dd037774f2d11e7c (patch)
tree345bc22d46b4e01a4ba8303b94278952a4ed2b9e /venv/lib/python3.7/site-packages/pip-10.0.1-py3.7.egg/pip/_vendor/html5lib/__init__.py
First commit
Diffstat (limited to 'venv/lib/python3.7/site-packages/pip-10.0.1-py3.7.egg/pip/_vendor/html5lib/__init__.py')
-rw-r--r--venv/lib/python3.7/site-packages/pip-10.0.1-py3.7.egg/pip/_vendor/html5lib/__init__.py35
1 files changed, 35 insertions, 0 deletions
diff --git a/venv/lib/python3.7/site-packages/pip-10.0.1-py3.7.egg/pip/_vendor/html5lib/__init__.py b/venv/lib/python3.7/site-packages/pip-10.0.1-py3.7.egg/pip/_vendor/html5lib/__init__.py
new file mode 100644
index 0000000..0b54002
--- /dev/null
+++ b/venv/lib/python3.7/site-packages/pip-10.0.1-py3.7.egg/pip/_vendor/html5lib/__init__.py
@@ -0,0 +1,35 @@
1"""
2HTML parsing library based on the `WHATWG HTML specification
3<https://whatwg.org/html>`_. The parser is designed to be compatible with
4existing HTML found in the wild and implements well-defined error recovery that
5is largely compatible with modern desktop web browsers.
6
7Example usage::
8
9 from pip._vendor import html5lib
10 with open("my_document.html", "rb") as f:
11 tree = html5lib.parse(f)
12
13For convenience, this module re-exports the following names:
14
15* :func:`~.html5parser.parse`
16* :func:`~.html5parser.parseFragment`
17* :class:`~.html5parser.HTMLParser`
18* :func:`~.treebuilders.getTreeBuilder`
19* :func:`~.treewalkers.getTreeWalker`
20* :func:`~.serializer.serialize`
21"""
22
23from __future__ import absolute_import, division, unicode_literals
24
25from .html5parser import HTMLParser, parse, parseFragment
26from .treebuilders import getTreeBuilder
27from .treewalkers import getTreeWalker
28from .serializer import serialize
29
30__all__ = ["HTMLParser", "parse", "parseFragment", "getTreeBuilder",
31 "getTreeWalker", "serialize"]
32
33# this has to be at the top level, see how setup.py parses this
34#: Distribution version number.
35__version__ = "1.0.1"