summaryrefslogtreecommitdiff
path: root/modules/neovim.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/neovim.nix')
-rw-r--r--modules/neovim.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/modules/neovim.nix b/modules/neovim.nix
new file mode 100644
index 0000000..1897223
--- /dev/null
+++ b/modules/neovim.nix
@@ -0,0 +1,34 @@
1{ config, pkgs, ... }:
2
3{
4 programs.neovim = {
5 enable = true;
6 defaultEditor = true;
7 viAlias = true;
8 vimAlias = true;
9 vimdiffAlias = true;
10 extraConfig = builtins.readFile ./init.vim;
11 plugins = with pkgs.vimPlugins; [
12 # lsp
13 nvim-lspconfig
14 nvim-cmp
15 (nvim-treesitter.withPlugins (_: pkgs.tree-sitter.allGrammars))
16 # autocompletion
17 cmp-nvim-lsp
18 cmp-buffer
19 cmp-path
20 cmp-cmdline
21 # tpope
22 vim-surround
23 vim-fugitive
24 # syntax
25 vim-nix
26 vimtex
27 # others
28 vim-gitgutter
29 tabular
30 vimwiki
31 fzf-vim
32 ];
33 };
34}