summaryrefslogtreecommitdiff
path: root/hosts/oracle/home.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/oracle/home.nix')
-rw-r--r--hosts/oracle/home.nix47
1 files changed, 47 insertions, 0 deletions
diff --git a/hosts/oracle/home.nix b/hosts/oracle/home.nix
new file mode 100644
index 0000000..0ec8399
--- /dev/null
+++ b/hosts/oracle/home.nix
@@ -0,0 +1,47 @@
1{ config, pkgs, ... }:
2
3{
4 home.username = "shubh";
5 home.homeDirectory = "/home/shubh";
6
7 # You should not change this value, even if you update Home Manager. If you do
8 # want to update the value, then make sure to first check the Home Manager
9 # release notes.
10 home.stateVersion = "23.05";
11
12 home.packages = with pkgs; [
13 git
14 unzip
15 wget
16 gnupg
17 pinentry
18 wl-clipboard
19 pass
20 tmux
21 fzf
22 firefox
23 libreoffice-qt
24 # (pkgs.nerdfonts.override { fonts = [ "FantasqueSansMono" ]; })
25 ];
26
27 imports = [
28 ./modules/common.nix
29 ];
30
31 services.gpg-agent = {
32 enable = true;
33 pinentryFlavor = "qt";
34 };
35
36 xdg = {
37 userDirs = {
38 enable = true;
39 desktop = "\$HOME/desktop";
40 documents = "\$HOME/docs";
41 download = "\$HOME/downloads";
42 pictures = "\$HOME/pics";
43 music = "\$HOME/music";
44 videos = "\$HOME/vids";
45 };
46 };
47}