summaryrefslogtreecommitdiff
path: root/hosts/morpheus/home.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/morpheus/home.nix')
-rw-r--r--hosts/morpheus/home.nix50
1 files changed, 50 insertions, 0 deletions
diff --git a/hosts/morpheus/home.nix b/hosts/morpheus/home.nix
new file mode 100644
index 0000000..1188c65
--- /dev/null
+++ b/hosts/morpheus/home.nix
@@ -0,0 +1,50 @@
1{ config, pkgs, ... }:
2
3{
4 home.username = "shubh";
5 home.homeDirectory = "/Users/shubh";
6
7 # You should not change this value, even if you update Home Manager. If you do
8 # want to update the value, then make sure to first check the Home Manager
9 # release notes.
10 home.stateVersion = "23.05";
11
12 home.packages = with pkgs; [
13 git
14 unzip
15 wget
16 gnupg
17 pass
18 tmux
19 fzf
20 docker
21 neovim
22 nmap
23 lf
24 pinentry_mac
25 postgresql
26 docker
27 kubectl
28 kubelogin-oidc
29 terraform
30 kops
31 k9s
32 kubernetes-helm
33 python38
34 # gui
35 zoom-us
36 slack
37 ];
38
39 home.file = {
40 ".gnupg/gpg-agent.conf" = {
41 text = ''
42 pinentry-program ${pkgs.pinentry_mac}/Applications/pinentry-mac.app/Contents/MacOS/pinentry-mac
43 '';
44 };
45 };
46
47 imports = [
48 ../modules/common.nix
49 ];
50}